Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundacji Dzieciom zdazyć z Pomocą.
Więcej informacji na dug.net.pl/pomagamy/.

#1  2008-01-26 14:28:49

  Outlaw - Użytkownik

Outlaw
Użytkownik
Zarejestrowany: 2007-10-20
Serwis

apt-get i duży problem...

Chciałem doinstalować spamassassina do VHCS korzystam z tej strony:

http://vhcs.puuhis.net/wi...ntivirus_filter

Przy wydaniu pierwszego polecenia instalacji to apt-get chce mi usunąć 
cztery pakiety...

Kod:

Następujące pakiety zostaną USUNIĘTE:
   base-config initrd-tools kernel-image-2.6.8-2-686-smp libnet-perl

instalacja poszla dalej, ale przerwalem ja i boje sie ze usunelo mi te 
pakety... chcialo tez zaaktualizowac glibc... przy upgrade slackware wiem 
ze z zmiana glibc byly duze problemy... takze przerwalem instalacje bojac 
sie ze serwer juz sie nie podniesie.

Może wrzuce co mi wywala... przy instalcji jednego z usuniętych pakietów

Kod:

host:~# apt-get install base-config
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności... Gotowe
Pakiet base-config nie ma dostępnej wersji, ale odnosi się do niego inny pakiet.
Zazwyczaj oznacza to, że pakietu brakuje, został zastąpiony przez inny
pakiet lub nie jest dostępny przy pomocy obecnie ustawionych źródeł.
Jednak następujące pakiety go zastępują:
  locales belocs-locales-bin
E: Pakiet base-config nie ma kandydata do instalacji
host:~# apt-get install belocs-locales-bin
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności... Gotowe
Należy uruchomić `apt-get -f install', aby je naprawić:
Następujące pakiety mają niespełnione zależności:
  belocs-locales-bin: Wymaga: libc6 (>= 2.3.6-6) ale 2.3.2.ds1-22 ma zostać zainstalowany
                      Wymaga: belocs-locales-data ale nie ma zostać zainstalowany
  libc6-dev: Wymaga: libc6 (= 2.3.6.ds1-13etch4) ale 2.3.2.ds1-22 ma zostać zainstalowany
  locales: Wymaga: glibc-2.3.6.ds1-1
           Jest w konflikcie z: belocs-locales-bin ale 2.4-2.1 ma zostać zainstalowany
E: Niespełnione zależności. Spróbuj 'apt-get -f install' bez pakietów (lub podaj rozwiązanie).
host:~# apt-get -f install
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności... Gotowe
Naprawianie zależności... Gotowe
Zostaną zainstalowane następujące dodatkowe pakiety:
  libc6
Sugerowane pakiety:
  glibc-doc
Następujące pakiety zostaną zaktualizowane:
  libc6
1 zaktualizowanych, 0 nowo zainstalowanych, 0 do usunięcia i 449 nie zaktualizowanych.
3 nie w pełni zainstalowanych lub usuniętych.
Konieczne pobranie 0B/4700kB archiwów.
Po rozpakowaniu zostanie zwolnione 4854kB miejsca na dysku.
Czy chcesz kontynuować? [T/n] T
Pob: 1 ftp://ftp.pl.debian.org stable/main libc6 2.3.6.ds1-13etch4 [4700kB]
Pobrano 4700kB w 7s (630kB/s)                                                            
(Odczytywanie bazy danych ... 39796 plików i katalogów obecnie zainstalowanych.)
Przygotowanie do zastąpienia libc6 2.3.2.ds1-22 (wykorzystując .../libc6_2.3.6.ds1-13etch4_i386.deb) ...

Name Service Switch update in the C Library: pre-installation question.

Running services and programs that are using NSS need to be restarted,
otherwise they might not be able to do lookup or authentication any more.
The installation process is able to restart some services (such as ssh or
telnetd), but other programs cannot be restarted automatically.  One such
program that needs manual stopping and restart after the glibc upgrade by
yourself is xdm - because automatic restart might disconnect your active
X11 sessions.

Known packages that need to be stopped before the glibc upgrade are:
        xdm kdm gdm postgresql xscreensaver

This script did not detect any installed services which need to be
stopped.

If you want to interrupt the upgrade now and continue later, please
answer No to the question below.

Do you want to upgrade glibc now? [Y/n]

Błędy zależości libc mam przy próbie instalacji czegokolwiek przez apt-get... jak się za to zabrać... :(

Obecnie mam w repozytorium sarge a wcześniej miałem:

Kod:

deb http://security.debian.org/ stable/updates main contrib non-free

deb ftp://ftp.pl.debian.org/debian/ stable main non-free contrib
deb-src ftp://ftp.pl.debian.org/debian/ stable main non-free contrib


deb http://ftp.icm.edu.pl/pub/Linux/debian/ stable main non-free contrib
deb-src http://ftp.icm.edu.pl/pub/Linux/debian/ stable main non-free contrib

Próbowałem przeładować lilo... no i wywala że nie może znaleść obrazu, obawiam się że właśnie paczkę z kernelem też coś wywaliło... puki co serwer chodzi, ale obawiam się że przy restarcie będzie niemały problem... Jak do tego wszystkiego się zabrać żeby nie było problemu, bo chyba nie musze dodawać że przerwa w pracy serwera jest niemile widziana... :(:(:(:(


http://blog.outlaw.one.pl
[url=http://siecikomputerowe.bydgoszcz.pl]Okablowanie strukturalne, sieci komputerowe, Bydgoszcz, Poznań, Toruń, Piła.[/url]
[url=http://netria.pl]Internet, Okablowanie strukturalne, sieci komputerowe, Bydgoszcz, Poznań, Piła, Toruń, Czersk[/url]

Offline

 

#2  2008-01-26 16:32:01

  mariaczi - Użytkownik

mariaczi
Użytkownik
Zarejestrowany: 2007-10-02

Re: apt-get i duży problem...

Najwyrazniej zainstalowales spamassasina juz z Etch'a bo takowy jest obecnie stable. Zmien aby twoj apt korzystal z stable/etch i zaktualizuj dystrybujce.
Zainstaluj kernela i wszytsko powinno wrocic do normy.

Powodzenia!

Offline

 

#3  2008-01-26 16:38:53

  Outlaw - Użytkownik

Outlaw
Użytkownik
Zarejestrowany: 2007-10-20
Serwis

Re: apt-get i duży problem...

Czytałem o upgrade i większość miała dość problemów z tym... Boje się że jak zrobie upgrade to mi system padnie i serwer stanie ;/


http://blog.outlaw.one.pl
[url=http://siecikomputerowe.bydgoszcz.pl]Okablowanie strukturalne, sieci komputerowe, Bydgoszcz, Poznań, Toruń, Piła.[/url]
[url=http://netria.pl]Internet, Okablowanie strukturalne, sieci komputerowe, Bydgoszcz, Poznań, Piła, Toruń, Czersk[/url]

Offline

 

#4  2008-01-26 17:27:26

  bercik - Moderator Mamut

bercik
Moderator Mamut
Skąd: Warszawa
Zarejestrowany: 2006-09-23
Serwis

Re: apt-get i duży problem...

jakia wersje masz zainstalowana i jakie repo jest podane w /etc/apt/source ... bo wyglada na pmieszanie wersji ...


"Wszyscy wiedzą, że czegoś zrobić nie można. Ale przypadkowo znajduje się jakiś nieuk, który tego nie wie. I on właśnie robi odkrycie." (A.Einstein)

Offline

 

#5  2008-01-27 01:48:40

  Outlaw - Użytkownik

Outlaw
Użytkownik
Zarejestrowany: 2007-10-20
Serwis

Re: apt-get i duży problem...

Zainstalowana wersja Sarge
obecnie repo wygląda tak:
deb http://security.debian.org/ sarge/updates main contrib
deb http://ftp.pl.debian.org/debian/ sarge main non-free contrib

A lista pakietów tak:
http://outlaw.one.pl/lista.txt


http://blog.outlaw.one.pl
[url=http://siecikomputerowe.bydgoszcz.pl]Okablowanie strukturalne, sieci komputerowe, Bydgoszcz, Poznań, Toruń, Piła.[/url]
[url=http://netria.pl]Internet, Okablowanie strukturalne, sieci komputerowe, Bydgoszcz, Poznań, Piła, Toruń, Czersk[/url]

Offline

 

#6  2008-01-27 08:28:10

  AgayKhan - Członek DUG

AgayKhan
Członek DUG
Skąd: Płock
Zarejestrowany: 2006-03-21
Serwis

Re: apt-get i duży problem...

[quote=Outlaw]Czytałem o upgrade i większość miała dość problemów z tym... Boje się że jak zrobie upgrade to mi system padnie i serwer stanie ;/[/quote]
Większość nie miała, tylko niektórzy. Ci, co nie miała, nie piszą na forach: Nie mam problemów z upgrade, pomóżcie.
Masz wymieszane oldstable ze stable. To zawsze skutkuje wielkim bubu. Musisz mieć albo sarge ( co nie polecam) albo etch ( czyli stable). A w obenym sources.list zapomnij o rozwiązaniu twoich problemów.
A po czorta mieszałeś oldstable ze stable? Teraz to masz kłopoty. Ale sam je chciałeś.

Kod:

deb http://security.debian.org/ stable/updates main contrib
deb http://ftp.pl.debian.org/debian/ stable main non-free contrib

Ostatnio edytowany przez AgayKhan (2008-01-27 08:28:55)


born to be root
linux register user #362473

Offline

 

#7  2008-01-27 10:23:18

  Outlaw - Użytkownik

Outlaw
Użytkownik
Zarejestrowany: 2007-10-20
Serwis

Re: apt-get i duży problem...

Zmieniłem sobie
deb http://security.debian.org/ oldstable/updates main contrib
deb http://ftp.pl.debian.org/debian/ oldstable main non-free contrib

bo chce powrócić do poprzedniego stanu, wywala mi teraz:

Kod:

host:~# apt-get install belocs-locales-bin locales
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności... Gotowe
locales jest już w najnowszej wersji.
Należy uruchomić `apt-get -f install', aby je naprawić:
Następujące pakiety mają niespełnione zależności:
  belocs-locales-bin: Wymaga: belocs-locales-data ale nie ma zostać zainstalowany
  libc6-dev: Wymaga: libc6 (= 2.3.6.ds1-13etch4) ale 2.3.2.ds1-22 ma zostać zainstalowany
  locales: Wymaga: glibc-2.3.6.ds1-1 ale nie da się go zainstalować
           Jest w konflikcie z: belocs-locales-bin ale 2.3.4-8 ma zostać zainstalowany
E: Niespełnione zależności. Spróbuj 'apt-get -f install' bez pakietów (lub podaj rozwiązanie).
host:~# apt-get -f install
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności... Gotowe
Naprawianie zależności... Gotowe
Następujące pakiety zostaną USUNIĘTE:
  g++ g++-3.3 language-env libc6-dev libjpeg-mmx-dev libjpeg62-dev libncurses5-dev
  libnet0-dev libpcap0.8-dev libreadline4-dev libstdc++5-3.3-dev locales
  localization-config zlib1g-dev
0 zaktualizowanych, 0 nowo zainstalowanych, 14 do usunięcia i 120 nie zaktualizowanych.
4 nie w pełni zainstalowanych lub usuniętych.
Konieczne pobranie 0B archiwów.
Po rozpakowaniu zostanie zwolnione 39,4MB miejsca na dysku.
Czy chcesz kontynuować? [T/n] n
Przerwane.

Porównując te pakiety do usunięcia z listą stwierdzam że się one powtarzają oprócz g++ g++-3.3 i locales. Reszta ma swoje odpowiedniki tylko bez "-dev" Czy mogę bez żadnych konsekwencji je usunąć i wtedy myślę że wszystko wróci do normy...?

Ostatnio edytowany przez Outlaw (2008-01-27 10:36:09)


http://blog.outlaw.one.pl
[url=http://siecikomputerowe.bydgoszcz.pl]Okablowanie strukturalne, sieci komputerowe, Bydgoszcz, Poznań, Toruń, Piła.[/url]
[url=http://netria.pl]Internet, Okablowanie strukturalne, sieci komputerowe, Bydgoszcz, Poznań, Piła, Toruń, Czersk[/url]

Offline

 

#8  2008-01-27 10:53:15

  AgayKhan - Członek DUG

AgayKhan
Członek DUG
Skąd: Płock
Zarejestrowany: 2006-03-21
Serwis

Re: apt-get i duży problem...

sarge = oldstable. Nic nie zmieniłeś. Nic. Dałem ci już gotowe sources.list.
Ale ty dalej jak koń pod górkę.


born to be root
linux register user #362473

Offline

 

#9  2008-01-27 11:07:36

  Outlaw - Użytkownik

Outlaw
Użytkownik
Zarejestrowany: 2007-10-20
Serwis

Re: apt-get i duży problem...

NO dałeś mi do etcha bo jest stable tak? zmieniłem na oldstable bo chce wrócić do stanu poprzedniego. Większość pakietów mam Sarge bo takową wersje mam na sewerze...
No chyba że źle się rozumiemy, bo za bardzo w debianie sie nie orientuje.


http://blog.outlaw.one.pl
[url=http://siecikomputerowe.bydgoszcz.pl]Okablowanie strukturalne, sieci komputerowe, Bydgoszcz, Poznań, Toruń, Piła.[/url]
[url=http://netria.pl]Internet, Okablowanie strukturalne, sieci komputerowe, Bydgoszcz, Poznań, Piła, Toruń, Czersk[/url]

Offline

 

#10  2008-01-27 12:00:43

  Bodzio - Ojciec Założyciel

Bodzio
Ojciec Założyciel
Skąd: Gorlice
Zarejestrowany: 2004-04-17
Serwis

Re: apt-get i duży problem...

[url=http://dug.net.pl/faq/faq-6-142-Downgrade.php]>>tu poczytaj<<[/url] o downgrade, czyli przejściu z wyższej na niższą


Debian jest lepszy niż wszystkie klony
Linux register users: #359018
[img]http://www.freebsd.org/gifs/powerlogo.gif[/img]
[url=https://goo.gl/photos/5XGKFkvaMimLwM2s9]Beskid Niski[/url]

Offline

 

#11  2008-01-27 12:56:15

  Outlaw - Użytkownik

Outlaw
Użytkownik
Zarejestrowany: 2007-10-20
Serwis

Re: apt-get i duży problem...

Dobra już problem rozwiązany AgayKhan pomógł mi prze komunikator, za co mu serdecznie dziękuje!

Zostaje jeszcze problem z kernelem ;/


http://blog.outlaw.one.pl
[url=http://siecikomputerowe.bydgoszcz.pl]Okablowanie strukturalne, sieci komputerowe, Bydgoszcz, Poznań, Toruń, Piła.[/url]
[url=http://netria.pl]Internet, Okablowanie strukturalne, sieci komputerowe, Bydgoszcz, Poznań, Piła, Toruń, Czersk[/url]

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)

[ Generated in 0.044 seconds, 9 queries executed ]

Informacje debugowania

Time (s) Query
0.00032 SET CHARSET latin2
0.00013 SET NAMES latin2
0.00176 SELECT u.*, g.*, o.logged FROM punbb_users AS u INNER JOIN punbb_groups AS g ON u.group_id=g.g_id LEFT JOIN punbb_online AS o ON o.ident='54.237.183.249' WHERE u.id=1
0.01083 UPDATE punbb_online SET logged=1600677703 WHERE ident='54.237.183.249'
0.00046 SELECT * FROM punbb_online WHERE logged<1600677403
0.00053 SELECT t.subject, t.closed, t.num_replies, t.sticky, f.id AS forum_id, f.forum_name, f.moderators, fp.post_replies, 0 FROM punbb_topics AS t INNER JOIN punbb_forums AS f ON f.id=t.forum_id LEFT JOIN punbb_forum_perms AS fp ON (fp.forum_id=f.id AND fp.group_id=3) WHERE (fp.read_forum IS NULL OR fp.read_forum=1) AND t.id=10451 AND t.moved_to IS NULL
0.00008 SELECT search_for, replace_with FROM punbb_censoring
0.00158 SELECT u.email, u.title, u.url, u.location, u.use_avatar, u.signature, u.email_setting, u.num_posts, u.registered, u.admin_note, p.id, p.poster AS username, p.poster_id, p.poster_ip, p.poster_email, p.message, p.hide_smilies, p.posted, p.edited, p.edited_by, g.g_id, g.g_user_title, o.user_id AS is_online FROM punbb_posts AS p INNER JOIN punbb_users AS u ON u.id=p.poster_id INNER JOIN punbb_groups AS g ON g.g_id=u.group_id LEFT JOIN punbb_online AS o ON (o.user_id=u.id AND o.user_id!=1 AND o.idle=0) WHERE p.topic_id=10451 ORDER BY p.id LIMIT 0,25
0.01387 UPDATE punbb_topics SET num_views=num_views+1 WHERE id=10451
Total query time: 0.02956 s