Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundacji Dzieciom zdazyć z Pomocą.
Więcej informacji na dug.net.pl/pomagamy/.

#1  2018-08-25 13:30:35

  tur77ek - Użytkownik

tur77ek
Użytkownik
Zarejestrowany: 2018-08-25

Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

Witam, przeszedłem na serwer vps debian 9 do prawidłowego działania skryptu który będę instalował potrzebuję zainstalować następujące pakiety

1/ PHP Version    Kohana requires PHP 7.1.0 or newer, this version is 7.0.30-0+deb9u1.

2/ GD2 library    Function imagegd2 does not exists! Image Processing and GD

dokładnie to widać na pliku testowym na domenie testowej http://www.solos.waw.pl/test.php

Z góry dzięki za pomoc:)

Ostatnio edytowany przez tur77ek (2018-08-25 13:31:37)

Offline

 

#2  2018-08-25 14:46:39

  arecki - Użytkownik

arecki
Użytkownik
Skąd: 44 Bronson Lane Hensonville
Zarejestrowany: 2016-03-03

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

PHP 7.1 jest dopiero w edycji Buster
Bez sprawdzania -> https://tecadmin.net/install-php-debian-9-stretch/

Ostatnio edytowany przez arecki (2018-08-25 14:48:07)

Offline

 

#3  2018-08-25 15:58:56

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

Niekoniecznie:

Kod:

root ~> cat /etc/debian_version 
9.5

Kod:

root ~> php -v
PHP 7.1.20-1 (cli) (built: Aug  3 2018 03:45:34) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.1.20-1, Copyright (c) 1999-2018, by Zend Technologies

wystarczy w [b]/etc/apt/apt.conf[/b] ustawić:

Kod:

APT::Default-Release "stable";

potem dodać repo testinga/bustera, zaktualizować bazę apta,  i potem magiczne polecenie:

Kod:

aptitude install -t testing php-cośtam

SOA#1


PS:
Caly używany przeze mnie [b]/etc/apt/apt.conf[/b]:

Kod:

APT::Default-Release "stable";
APT::Get::Install-Recommends "false";
APT::Get::Install-Suggests "false";
Apt::Get::Purge;
Acquire::PDiffs "true";

Dpkg::Options {
   "--force-confdef";
   "--force-confold";
}

Dpkg::Progress-Fancy "1";
APT::Color "1";

PS2:
W Debianie na serwerach internetowych lepiej uważać z nieoficjalnymi repozytoriami prowadzonymi przez diabli wiedzą kogo, zwłaszcza, jak wystarczą oficjalne repozytoria projektu Debian.

Pozdro

Ostatnio edytowany przez Jacekalex (2018-08-25 16:22:11)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#4  2018-08-25 16:32:13

  tur77ek - Użytkownik

tur77ek
Użytkownik
Zarejestrowany: 2018-08-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

po wpisaniu cat /etc/debian_version mam wersję 9.5

po wpisaniu php -v wyskoczyło

PHP 7.0.30-0+deb9u1 (cli) (built: Jun 14 2018 13:50:25) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.30-0+deb9u1, Copyright (c) 1999-2017, by Zend Technol

ustawiłem w /etc/apt/apt.conf poprzez wpisanie nano /etc/apt/apt.conf

APT::Default-Release "stable";

jak dodać repo testinga/bustera ?

Czy na debianie 8 jest PHP którego potrzebuje mój skrypt w podstawowym repo ?

Ostatnio edytowany przez tur77ek (2018-08-25 16:37:43)

Offline

 

#5  2018-08-25 16:58:13

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

jak dodać repo testinga/bustera ?[/quote]
Bawisz się w adminkę VPsem na Debianie, a nie wiesz, jak się edytuje /etc/apt/sources.list i dodaje repozytoria?

Tu na forum w FAQ&HOWTO masz spis repozytoriów, podobnie jak w oficjalnej dokumentacji Debiana.

Np tutaj:
https://wiki.debian.org/SourcesList

PHP-7.1.20 jest w oficjanym repozytorium Debiana dla dystrybucji Debian 10 Buster (obecnie testing).

Ostatnio edytowany przez Jacekalex (2018-08-25 17:01:44)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#6  2018-08-25 16:58:58

  yossarian - Szczawiożerca

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

Zainteresuj się takimi narzędziami jak Docker lub LXC.
Wtedy możesz się bawić różnymi wersjami oprogramowania, nie tracąc stabilności i jakości swojego systemu.

Offline

 

#7  2018-08-25 17:06:11

  tur77ek - Użytkownik

tur77ek
Użytkownik
Zarejestrowany: 2018-08-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

Liczyłem na pomoc krok po kroku wklejanie w putty to co trzeba aby zadziałało potrzebuję po prostu uruchomić automat aby pozycjonować stronę firmową i tyle z racji wieku raczej nie rozkminię tego sam, zainstalowałem panel vesta początkowa konfiguracja i działa teraz liczę na pomoc przy php ale metoda skopiuj i wklej

Ostatnio edytowany przez tur77ek (2018-08-25 17:06:41)

Offline

 

#8  2018-08-25 17:06:38

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

[quote=yossarian]Zainteresuj się takimi narzędziami jak Docker lub LXC.
Wtedy możesz się bawić różnymi wersjami oprogramowania, nie tracąc stabilności i jakości swojego systemu.[/quote]
Z całym szacunkiem, ale chrooty na sterydach jak LXC czy kontenery Docker nieszczególnie się w tej chwili przydadzą komuś, kto pyta, jak się dodaje repozytoria w Debianie.

Chociaż faktycznie, niewiele tu wątków długością przypominających "[url=https://forum.dug.net.pl/viewtopic.php?id=16056]Szkołę Rodzenia Gentoo[/url]"
xD


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#9  2018-08-25 17:13:48

  yossarian - Szczawiożerca

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

Mieszanie wersji stabilnej z testową może skończyć się równie długim wątkiem ;-)

…chrooty na sterydach…[/quote]
Mijają lata, a Ty ciągle w średniowieczu ;)

Poczytaj trochę o współczesnych narzędziach.

Offline

 

#10  2018-08-25 17:21:11

  tur77ek - Użytkownik

tur77ek
Użytkownik
Zarejestrowany: 2018-08-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

Czy na centosie albo debianie 8 będzie dostępne potrzebne php i biblioteka GD2 library ?

Ostatnio edytowany przez tur77ek (2018-08-25 17:21:28)

Offline

 

#11  2018-08-25 17:21:32

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

[quote=yossarian]Mieszanie wersji stabilnej z testową może skończyć się równie długim wątkiem ;-)...[/quote]
Po to własnie się ustawia zmienną APT::Default-Release,
żeby mieszanie wydań bajzlu nie robiło.

Mam tak zrobione na VPS, bo pieprzone Magento też PHP-7.1 wymagało,
na 7.0.30 nie chciało działać.
Jak na razie problemów brak, nic nie wybuchło, od 30 stycznia do dnia dzisiejszego.

[quote=tur77ek]Czy na centosie albo debianie 8 będzie dostępne potrzebne php i biblioteka GD2 library ?[/quote]
Na Debianie 8 na pewno nie, będzie w Debianie 10 (PHP-7.1).

W CentOS musisz sam sprawdzić, ale jak znam RH, to pewnie nie.

Zwłaszcza, że na VPSach w opcjach zazwyczaj jest pewien obsów czasowy
w porówaniu z rozwojem głównych dystrybucji.

Ostatnio edytowany przez Jacekalex (2018-08-25 17:31:31)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#12  2018-08-25 17:47:43

  tur77ek - Użytkownik

tur77ek
Użytkownik
Zarejestrowany: 2018-08-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

Chyba nie potrzebuję najnowszego php ponieważ sprawdziłem na hostingu współdzielonym na bizneshost ten skrypt chodził mi na php 5.6 (taka wersja ustawiona była dla domeny) to raczej chodzi chyba tylko o Kohana requires (cokolwiek to znaczy chyba jakiś Framework) i brakuje mi GD2 library muszę to doinstalować.

zobaczcie http://www.solos.waw.pl/test.php

Ostatnio edytowany przez tur77ek (2018-08-25 18:11:08)

Offline

 

#13  2018-08-25 17:55:22

  yossarian - Szczawiożerca

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

[deb]php-gd[/deb] zainstalowane?

Offline

 

#14  2018-08-25 18:01:55

  tur77ek - Użytkownik

tur77ek
Użytkownik
Zarejestrowany: 2018-08-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

po wpisaniu

dpkg -l

php            1:7.0+49     all          server-side, HTML-embedded script
ii  php-auth-sasl  1.0.6-3      all          Abstraction of various SASL mecha
ii  php-cgi        1:7.0+49     all          server-side, HTML-embedded script
ii  php-common     1:49         all          Common files for PHP packages
ii  php-curl       1:7.0+49     all          CURL module for PHP [default]
ii  php-intl       1:7.0+49     all          Internationalisation module for P
ii  php-mail-mime  1.10.0-2     all          PHP PEAR module for creating MIME
ii  php-mbstring   1:7.0+49     all          MBSTRING module for PHP [default]
ii  php-mcrypt     1:7.0+49     all          libmcrypt module for PHP [default
ii  php-mysql      1:7.0+49     all          MySQL module for PHP [default]
ii  php-net-smtp   1.7.1-2      all          PHP PEAR module implementing SMTP
ii  php-net-socket 1.0.14-2     all          Network Socket Interface
ii  php-pear       1:1.10.1+sub all          PEAR Base System
ii  php-php-gettex 1.0.12-0.1   all          read gettext MO files directly, w
ii  php-phpseclib  2.0.4-1      all          implementations of an arbitrary-p
ii  php-xml        1:7.0+49     all          DOM, SimpleXML, WDDX, XML, and XS
ii  php7.0         7.0.30-0+deb all          server-side, HTML-embedded script
ii  php7.0-cgi     7.0.30-0+deb amd64        server-side, HTML-embedded script
ii  php7.0-cli     7.0.30-0+deb amd64        command-line interpreter for the
ii  php7.0-common  7.0.30-0+deb amd64        documentation, examples and commo
ii  php7.0-curl    7.0.30-0+deb amd64        CURL module for PHP
ii  php7.0-intl    7.0.30-0+deb amd64        Internationalisation module for P
ii  php7.0-json    7.0.30-0+deb amd64        JSON module for PHP
ii  php7.0-mbstrin 7.0.30-0+deb amd64        MBSTRING module for PHP
ii  php7.0-mcrypt  7.0.30-0+deb amd64        libmcrypt module for PHP
ii  php7.0-mysql   7.0.30-0+deb amd64        MySQL module for PHP
ii  php7.0-opcache 7.0.30-0+deb amd64        Zend OpCache module for PHP
ii  php7.0-readlin 7.0.30-0+deb amd64        readline module for PHP
ii  php7.0-xml     7.0.30-0+deb amd64        DOM, SimpleXML, WDDX, XML, and XS

Ostatnio edytowany przez tur77ek (2018-08-25 18:08:33)

Offline

 

#15  2018-08-25 18:17:54

  tur77ek - Użytkownik

tur77ek
Użytkownik
Zarejestrowany: 2018-08-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

apt-get install php-gd

zainstalowałem ale nadal brak efektu

Ostatnio edytowany przez tur77ek (2018-08-25 18:21:35)

Offline

 

#16  2018-08-25 18:21:40

  yossarian - Szczawiożerca

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

Bez urazy, ale albo ogarnij się trochę, nos w dokumentację i z czasem zaczynasz ogarniać temat, albo zleć to komuś kompetentnemu bo się do tego zwyczajnie nie nadajesz.

Takie zawracanie głowy innym przy braku elementarnych podstaw to totalne januszowanie.

Offline

 

#17  2018-08-25 18:27:11

  tur77ek - Użytkownik

tur77ek
Użytkownik
Zarejestrowany: 2018-08-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

No to dzięki wielkie za pomoc vpsa postawiłem dzisiaj czekałem tylko na gotowe regułki do wklepania, ok pozdrawiam chyba mi nie pomożecie szkoda za stary jestem czterdziecha na karku.

Ostatnio edytowany przez tur77ek (2018-08-25 18:28:46)

Offline

 

#18  2018-08-25 18:42:50

  yossarian - Szczawiożerca

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

[quote=tur77ek]…czekałem tylko na gotowe regułki do wklepania, […] chyba mi nie pomożecie szkoda…[/quote]
Właśnie problem w tym, że nie na tym polega „pomoc”.

A na konkretne pytania oczywiście ktoś na forum odpowie. Tylko bez takich jaj jak powyżej.

Offline

 

#19  2018-08-25 18:46:03

  arecki - Użytkownik

arecki
Użytkownik
Skąd: 44 Bronson Lane Hensonville
Zarejestrowany: 2016-03-03

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

Skorzystaj z tego co JacekAlex podał lub po prostu całego vps migruj do testinga i po kłopocie.

Ostatnio edytowany przez arecki (2018-08-25 18:49:41)

Offline

 

#20  2018-08-25 18:50:30

  yossarian - Szczawiożerca

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

A po co ma migrować, jak wersja PHP pasuje?

A autor wątku, gdy już doczyta w dokumentacji, będzie wiedział, że po instalacji modułu trzeba go jeszcze włączyć i zrestartować/przeładować apacha czy czego tam używa.

Offline

 

#21  2018-08-25 18:56:00

  arecki - Użytkownik

arecki
Użytkownik
Skąd: 44 Bronson Lane Hensonville
Zarejestrowany: 2016-03-03

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

Z tego co autor wrzucił to skrypt wymaga php w wersji 7.1.
Sugerujesz, że Kohana ruszy na php 7.0?

Kohana requires PHP 7.1.0 or newer, this version is 7.0.30-0+deb9u1.[/quote]

Ostatnio edytowany przez arecki (2018-08-25 19:00:10)

Offline

 

#22  2018-08-25 19:09:40

  yossarian - Szczawiożerca

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

Później niby wystarczała wersja 5.6:

Chyba nie potrzebuję najnowszego php ponieważ sprawdziłem na hostingu współdzielonym na bizneshost ten skrypt chodził mi na php 5.6[/quote]
Zresztą ciekawe co to za tajemniczy skrypt wymaga takiego trupa jak Kohana.

Offline

 

#23  2018-08-25 19:21:05

  arecki - Użytkownik

arecki
Użytkownik
Skąd: 44 Bronson Lane Hensonville
Zarejestrowany: 2016-03-03

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

Autor jak widać sam niewiele wie więc ciężko polegać na tym co pisze.
Jak migruje do testinga to spełni wymagania wersji php, to chyba najprostsze rozwiązanie, inne przerastają umiejętności autora.

Offline

 

#24  2018-08-25 21:28:00

  tur77ek - Użytkownik

tur77ek
Użytkownik
Zarejestrowany: 2018-08-25

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

sudo apt install apt-transport-https lsb-release ca-certificates
sudo wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
sudo sh -c 'echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php.list'
sudo apt update

sudo apt install php7.1

sudo apt install php7.1-gd php7.1-mbstring php7.1-xml php7.1-cli php7.1-json

Offline

 

#25  2018-08-25 21:46:48

  arecki - Użytkownik

arecki
Użytkownik
Skąd: 44 Bronson Lane Hensonville
Zarejestrowany: 2016-03-03

Re: Instalacja Kohana requires PHP i GD2 library na VPS Debian 9

Co chcesz nam przez to przekazać, poza brakiem znaczników kodu?

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Możesz wyłączyć AdBlock — tu nie ma reklam ;-)

[ Generated in 0.010 seconds, 9 queries executed ]

Informacje debugowania

Time (s) Query
0.00012 SET CHARSET latin2
0.00008 SET NAMES latin2
0.00052 SELECT u.*, g.*, o.logged FROM punbb_users AS u INNER JOIN punbb_groups AS g ON u.group_id=g.g_id LEFT JOIN punbb_online AS o ON o.ident='44.201.99.222' WHERE u.id=1
0.00097 UPDATE punbb_online SET logged=1669706176 WHERE ident='44.201.99.222'
0.00044 SELECT * FROM punbb_online WHERE logged<1669705876
0.00052 SELECT t.subject, t.closed, t.num_replies, t.sticky, f.id AS forum_id, f.forum_name, f.moderators, fp.post_replies, 0 FROM punbb_topics AS t INNER JOIN punbb_forums AS f ON f.id=t.forum_id LEFT JOIN punbb_forum_perms AS fp ON (fp.forum_id=f.id AND fp.group_id=3) WHERE (fp.read_forum IS NULL OR fp.read_forum=1) AND t.id=30600 AND t.moved_to IS NULL
0.00005 SELECT search_for, replace_with FROM punbb_censoring
0.00201 SELECT u.email, u.title, u.url, u.location, u.use_avatar, u.signature, u.email_setting, u.num_posts, u.registered, u.admin_note, p.id, p.poster AS username, p.poster_id, p.poster_ip, p.poster_email, p.message, p.hide_smilies, p.posted, p.edited, p.edited_by, g.g_id, g.g_user_title, o.user_id AS is_online FROM punbb_posts AS p INNER JOIN punbb_users AS u ON u.id=p.poster_id INNER JOIN punbb_groups AS g ON g.g_id=u.group_id LEFT JOIN punbb_online AS o ON (o.user_id=u.id AND o.user_id!=1 AND o.idle=0) WHERE p.topic_id=30600 ORDER BY p.id LIMIT 0,25
0.00117 UPDATE punbb_topics SET num_views=num_views+1 WHERE id=30600
Total query time: 0.00588 s