Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundacji Dzieciom zdazyć z Pomocą.
Więcej informacji na dug.net.pl/pomagamy/.

#1  2017-11-24 00:56:10

  trzczy - Użytkownik

trzczy
Użytkownik
Zarejestrowany: 2016-12-16

Windows 10 ICS kaput z modemem Huawei E272 (z Nokia 7m-01 było ok)

Mowa cały czas będzie o LAN przez kabel. Na lapku mam debiana Stretch i pobieram internet z innych kompów. Raz z jednego, raz z drugiego. Internet przychodzi z mobilnego Orange przez modem Huawei E272. Kiedy próbuję ten internet udostępnić z kompa Windows 10 oraz z kompa z Windows 8, to na lapku niestety nie ma internetu.

Natomiast zupełnie ok jest, gdy z tego samego modemu udostępniam internet z kompa z debianem Stretch.

Czyli działa debian ----> debian, a nie działa Windows -----> debian

Moje pytanie dotyczy uruchomienia udostępniania internetu na Windows. Robię normalnie ICS z tym modemem. Wypróbowałem 2 wersje programu "Play Online" i jedną wersję "Mobile partner". Internet działa na tym Windowsie normalnie w Chrome, w okienku Połączeń pokazuje się przy ikonie modemu napis "Shared", a na lapku z debianem internetu nie ma. Wtyczki kabla migają i debian uzyskuje poprawne adresy przez DHCP. Zapuściłem na lapku kilka komend związanych z testowaniem sieci:

Kod:

root@debian:/home/mann# traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
 1  MOC.mshome.net (192.168.137.1)  0.437 ms !N * *
root@debian:/home/mann# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
92 bytes from MOC.mshome.net (192.168.137.1): Destination Net Unreachable
92 bytes from MOC.mshome.net (192.168.137.1): Destination Net Unreachable
92 bytes from MOC.mshome.net (192.168.137.1): Destination Net Unreachable
92 bytes from MOC.mshome.net (192.168.137.1): Destination Net Unreachable
92 bytes from MOC.mshome.net (192.168.137.1): Destination Net Unreachable
^C--- 8.8.8.8 ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss
root@debian:/home/mann# arp -n
Address                  HWtype  HWaddress           Flags Mask            Iface
192.168.137.1            ether   00:23:54:60:da:20   C                     enp0s25
root@debian:/home/mann# mii-tool enp0s25
enp0s25: negotiated 100baseTx-FD flow-control, link ok
root@debian:/home/mann# ip route
default via 192.168.137.1 dev enp0s25 proto static metric 100 
169.254.0.0/16 dev enp0s25 scope link metric 1000 
192.168.137.0/24 dev enp0s25 proto kernel scope link src 192.168.137.117 metric 100 
root@debian:/home/mann# ip neigh
192.168.137.1 dev enp0s25 lladdr 00:23:54:60:da:20 DELAY
root@debian:/home/mann# ifconfig enp0s25
enp0s25: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.137.117  netmask 255.255.255.0  broadcast 192.168.137.255
        inet6 fe80::221:86ff:fe61:8813  prefixlen 64  scopeid 0x20<link>
        ether 00:21:86:61:88:13  txqueuelen 1000  (Ethernet)
        RX packets 25817  bytes 9026142 (8.6 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 27289  bytes 3422151 (3.2 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 20  memory 0xfc000000-fc020000  

root@debian:/home/mann# nmcli dev show | grep 'DNS'
IP4.DNS[1]:                             192.168.137.1

Najważniejszy jest chyba bezskuteczny ping do 8.8.8.8. (Aha, ping do bramy 192.168.137.1 działa).

I teraz poradźcie, jak szukać rozwiązania. Wydaje się, że problem nie  leży w lapku, ale w Windows ICS, bo lapek bezproblemowo pobiera internet z debiana. Dodam, że miesiąc temu, jak miałem tę samą kartę Orange w modemie Nokia 7M-01, to lapek ładnie ciągnął internet z Windows 10. Ale tamten modem się zepsuł.
Z góry dziękuję

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)

[ Generated in 0.036 seconds, 12 queries executed ]

Informacje debugowania

Time (s) Query
0.00036 SET CHARSET latin2
0.00011 SET NAMES latin2
0.00155 SELECT u.*, g.*, o.logged FROM punbb_users AS u INNER JOIN punbb_groups AS g ON u.group_id=g.g_id LEFT JOIN punbb_online AS o ON o.ident='3.236.59.63' WHERE u.id=1
0.00572 UPDATE punbb_online SET logged=1594635028 WHERE ident='3.236.59.63'
0.00048 SELECT * FROM punbb_online WHERE logged<1594634728
0.00867 DELETE FROM punbb_online WHERE ident='46.229.168.154'
0.00009 SELECT topic_id FROM punbb_posts WHERE id=315725
0.00007 SELECT id FROM punbb_posts WHERE topic_id=30081 ORDER BY posted
0.00072 SELECT t.subject, t.closed, t.num_replies, t.sticky, f.id AS forum_id, f.forum_name, f.moderators, fp.post_replies, 0 FROM punbb_topics AS t INNER JOIN punbb_forums AS f ON f.id=t.forum_id LEFT JOIN punbb_forum_perms AS fp ON (fp.forum_id=f.id AND fp.group_id=3) WHERE (fp.read_forum IS NULL OR fp.read_forum=1) AND t.id=30081 AND t.moved_to IS NULL
0.00014 SELECT search_for, replace_with FROM punbb_censoring
0.00167 SELECT u.email, u.title, u.url, u.location, u.use_avatar, u.signature, u.email_setting, u.num_posts, u.registered, u.admin_note, p.id, p.poster AS username, p.poster_id, p.poster_ip, p.poster_email, p.message, p.hide_smilies, p.posted, p.edited, p.edited_by, g.g_id, g.g_user_title, o.user_id AS is_online FROM punbb_posts AS p INNER JOIN punbb_users AS u ON u.id=p.poster_id INNER JOIN punbb_groups AS g ON g.g_id=u.group_id LEFT JOIN punbb_online AS o ON (o.user_id=u.id AND o.user_id!=1 AND o.idle=0) WHERE p.topic_id=30081 ORDER BY p.id LIMIT 0,25
0.01328 UPDATE punbb_topics SET num_views=num_views+1 WHERE id=30081
Total query time: 0.03286 s