Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundacji Dzieciom zdazyć z Pomocą.
Więcej informacji na dug.net.pl/pomagamy/.

#1  2019-02-04 14:16:02

  ZiemaF - Użytkownik

ZiemaF
Użytkownik
Skąd: Gliwice
Zarejestrowany: 2019-02-04

Intel i5-8600k Debian 9.7 problem z GPU i VAAPI

Witam,
Mam problem z uruchomieniem karty graficznej wbudowanej w procesor Intel i5-8600k pod Debian 9.6 oraz 9.7 i OMV (NAS na Debianie).
Zaznaczę od razu że pod Ubnuntu ten problem nie występuje, tam z kartą graficzną nie ma problemów.
Problem zauważyłem jak pod OMV na Docker chciałem uruchomić akcelerację kodowana pod EMBY poprzez VAAPI. Za nic w świecie nie udało mi się tego uruchomić.
Następnie zainstalowałem czystego Debiana 9.7 i próbowałem sprawdzić co vainfo pokarze na czystym systemie. efekt taki sam jak pod OMV.
[img]https://images91.fotosik.pl/118/73b91986b714c67cmed.jpg[/img]
W okienkach też tylko rozdzielczość 1024x768.<br/>
Zainstalowałem Ubuntu i tutaj nie ma żadnego problemu. vainfo zwróciło od razu taką informację:

Kod:

user@ubuntu:~$ sudo vainfo
[sudo] password for user:
error: XDG_RUNTIME_DIR not set in the environment.
error: can't connect to X server!
libva info: VA-API version 1.2.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_2
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.2 (libva 2.2.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Coffee Lake - 2.2.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSliceLP
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointEncSliceLP
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointEncSliceLP
      VAProfileH264MultiviewHigh      : VAEntrypointVLD
      VAProfileH264MultiviewHigh      : VAEntrypointEncSlice
      VAProfileH264StereoHigh         : VAEntrypointVLD
      VAProfileH264StereoHigh         : VAEntrypointEncSlice
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileJPEGBaseline           : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointEncPicture
      VAProfileVP8Version0_3          : VAEntrypointVLD
      VAProfileVP8Version0_3          : VAEntrypointEncSlice
      VAProfileHEVCMain               : VAEntrypointVLD
      VAProfileHEVCMain               : VAEntrypointEncSlice
      VAProfileHEVCMain10             : VAEntrypointVLD
      VAProfileHEVCMain10             : VAEntrypointEncSlice
      VAProfileVP9Profile0            : VAEntrypointVLD
      VAProfileVP9Profile0            : VAEntrypointEncSlice
      VAProfileVP9Profile2            : VAEntrypointVLD

Unity od razu włączyły się w 1920x1080.

Pod Debianem i OMV wgrałem kernel 4.19, i to też nic nie pomogło.
Sprzęt jest dobrze rozpoznany. Tutaj lspci z OMV:
[img]https://images91.fotosik.pl/118/c87b2e185ab582ecmed.jpg[/img]
Ma ktoś pomysł gdzie może być problem?

Z góry dziękuję za pomoc.

Offline

 

#2  2019-02-04 16:25:14

  jawojx - Użytkownik

jawojx
Użytkownik
Zarejestrowany: 2012-10-11

Re: Intel i5-8600k Debian 9.7 problem z GPU i VAAPI

Problem jest w tym że zainstalowałeś za starego Debiana do tego układu, i w repo i965-va-driver jest za stare. Najlepiej podnieś wersje do testinga, mrożenie zaczyna się już w lutym. Niby ciągle testowy, ale już niedługo.

Ostatnio edytowany przez jawojx (2019-02-04 16:31:36)

Offline

 

#3  2019-02-04 19:18:22

  ZiemaF - Użytkownik

ZiemaF
Użytkownik
Skąd: Gliwice
Zarejestrowany: 2019-02-04

Re: Intel i5-8600k Debian 9.7 problem z GPU i VAAPI

Dzięki za odpowiedź :-)
Ale w takim razie dalej mam problem, ponieważ OMV 4 opiera się na Debian 9,  testing to Debian 10.
Nie ma innej możliwości aby wymusić instalacje repo pod mój procesor na Debian 9?

Offline

 

#4  2019-02-04 19:50:54

  ilin - Palacz

ilin
Palacz
Skąd: PRLu
Zarejestrowany: 2006-05-03

Re: Intel i5-8600k Debian 9.7 problem z GPU i VAAPI

Przepakietować pakiet z gałęzi testing.


[b]Problemy rozwiązujemy na forum nie na PW[/b] -> Niech inni na tym skorzystają.
[url=http://dug.net.pl/]Polski portal Debiana[/url]

Offline

 

#5  2019-02-04 20:07:06

  ZiemaF - Użytkownik

ZiemaF
Użytkownik
Skąd: Gliwice
Zarejestrowany: 2019-02-04

Re: Intel i5-8600k Debian 9.7 problem z GPU i VAAPI

Już rozumiem w czym jest problem.
W Debian stretch pakiet i965-va-driver jest w wersji 1.7.3-1, która nie wspiera Coffee Lake
W Debian buster (aktualnie testowy) pakiet i965-va-driver jest w wersji 2.2.0+dfsg1-2, która już wspiera Coffee Lake, a nawet Cannon Lake.

Jak mam teraz "przepakietować pakiet" na ten z buster?
Aż taki biegły z Linuxa nie jestem.

Offline

 

#6  2019-02-04 21:05:06

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Intel i5-8600k Debian 9.7 problem z GPU i VAAPI

Możesz spokojnie do testinga zaktualizować, na Desktopie to nie będzie wielki problem,
a za kilka tygodni  Buster wchodzi w okres mrożenia, czyli ostatnią prostą do stabilnego wydania.

Na Desktopie testing czasem miewa błędy, ale nie wiąże się to z jakimś wielkim ryzykiem, takie błędy zazwyczaj jest dosyć łatwo  naprawić i  te, które się ujawnią
w czasie mrożenia,  są dość szybko łatane.

Ostatnio edytowany przez Jacekalex (2019-02-04 21:18:50)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#7  2019-02-05 07:36:53

  ZiemaF - Użytkownik

ZiemaF
Użytkownik
Skąd: Gliwice
Zarejestrowany: 2019-02-04

Re: Intel i5-8600k Debian 9.7 problem z GPU i VAAPI

Nie chcę całego systemu do testinga aktualizować.
OMV 4 opiera się na Debian 9, wiec zainstalował bym Debian 9 i tylko chciałbym ten sterownik doinstalować, a potem na tym zainstalować OMV 4 wg tej instrukcji [url]https://forum.openmediavault.org/index.php/Thread/21234-Install-OMV4-on-Debian-9-Stretch/[/url]
Zależy mi na stabilności systemu oraz uruchomieniu VAAPI na EMBY poprzez Dockera.

Offline

 

#8  2019-02-05 13:16:14

  jawojx - Użytkownik

jawojx
Użytkownik
Zarejestrowany: 2012-10-11

Re: Intel i5-8600k Debian 9.7 problem z GPU i VAAPI

[quote=ZiemaF]Nie chcę całego systemu do testinga aktualizować.[/quote]
To trzeba poeksperymentować póki nic tam nie masz. Dodaj repozytoria z testing-a ([b]Uwaga[/b], po zainstalowaniu wyłącz i włączaj jak będziesz aktualizował tylko te pakiety, lub ustaw odpowiednio pin-priority dla nich, bo się zagapisz i będziesz miał testing-a zaraz). Adres dla podstawowych z testing-a.

Kod:

deb http://deb.debian.org/debian buster main

Czy od razy z root-a zrób sobie oddzielny plik dla nich.

Kod:

echo "deb http://deb.debian.org/debian buster main" > /etc/apt/sources.list.d/testing.list

Jeżeli będą potrzebne nie wolne pakiety, to dodasz [b]contrib non-free[/b] na końcu linii, i można zainstalować wtedy nie wolny i965-va-driver-shaders.

I wiadomo (czasami nie rób upgrade).

Kod:

apt-get update

Doinstaluj nowy i965-va-driver. Ale to może być za mało, jak masz problemy z prawidłową rozdzielczością ekranu to pewnie będziesz musiał podnieść jeszcze xserver-xorg-video-intel (po co ci środowisko graficzne do serwera z openmediavault), a możliwe że i mesa będzie potrzebna nowsza. Jak wszystko zrobisz prawidłowo nie powinno być problemów, nie zapomnij o wyłączeniu repozytoriów testowych przed instalacją innych pakietów.


Edycja: Zamieniłem [b]testing[/b] na [b]buster[/b]. Niby to samo teraz, ale za chwile może mieć znaczenie.

Ostatnio edytowany przez jawojx (2019-02-05 13:31:15)

Offline

 

#9  2019-02-06 04:28:32

  wikingagressor - Użytkownik

wikingagressor
Użytkownik
Skąd: Józefów k.Błonia, mazowieck
Zarejestrowany: 2015-02-03

Re: Intel i5-8600k Debian 9.7 problem z GPU i VAAPI

Jest tez opcja zeby ustawic sobie system za pomoca [i]apt pinning[/i] tak, by baza byla oparta na stable, a tylko pakiety zwiazane z i965 byly z testinga.


Peace, Love and Debian for the World!!!

Offline

 

#10  2019-02-06 11:05:33

  jawojx - Użytkownik

jawojx
Użytkownik
Zarejestrowany: 2012-10-11

Re: Intel i5-8600k Debian 9.7 problem z GPU i VAAPI

[quote=wikingagressor]Jest tez opcja zeby ustawic sobie system za pomoca [i]apt pinning[/i] tak, by baza byla oparta na stable, a tylko pakiety zwiazane z i965 byly z testinga.[/quote]
No i po co to dublować, cytat:

[quote=jawojx]...po zainstalowaniu wyłącz i włączaj jak będziesz aktualizował tylko te pakiety, lub ustaw odpowiednio [b]pin-priority [/b]dla nich, bo się zagapisz i będziesz miał testing-a zaraz...[/quote]
Tylko nie pisz że nie czytałeś.

Offline

 

#11  2019-02-08 09:14:13

  ZiemaF - Użytkownik

ZiemaF
Użytkownik
Skąd: Gliwice
Zarejestrowany: 2019-02-04

Re: Intel i5-8600k Debian 9.7 problem z GPU i VAAPI

Udało mi się na OMV 4 zainstalować tylko te pakiety które potrzebowałem

Kod:

root@OMV:~# vainfo
error: XDG_RUNTIME_DIR not set in the environment.
error: can't connect to X server!
libva info: VA-API version 1.4.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_4
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.4 (libva 2.2.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Coffee Lake - 2.3.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSliceLP
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointEncSliceLP
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointEncSliceLP
      VAProfileH264MultiviewHigh      : VAEntrypointVLD
      VAProfileH264StereoHigh         : VAEntrypointVLD
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileJPEGBaseline           : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointEncPicture
      VAProfileVP8Version0_3          : VAEntrypointVLD
      VAProfileHEVCMain               : VAEntrypointVLD
      VAProfileHEVCMain10             : VAEntrypointVLD
      VAProfileVP9Profile0            : VAEntrypointVLD
      VAProfileVP9Profile2            : VAEntrypointVLD

Teraz będę robił testy z EMBY który jest postawiony na Dockerze.

Zrobiłem tak jak napisał jawojx

Ostatnio edytowany przez ZiemaF (2019-02-08 09:15:25)

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Możesz wyłączyć AdBlock — tu nie ma reklam ;-)

[ Generated in 0.012 seconds, 9 queries executed ]

Informacje debugowania

Time (s) Query
0.00010 SET CHARSET latin2
0.00004 SET NAMES latin2
0.00050 SELECT u.*, g.*, o.logged FROM punbb_users AS u INNER JOIN punbb_groups AS g ON u.group_id=g.g_id LEFT JOIN punbb_online AS o ON o.ident='3.234.143.26' WHERE u.id=1
0.00261 UPDATE punbb_online SET logged=1600762994 WHERE ident='3.234.143.26'
0.00020 SELECT * FROM punbb_online WHERE logged<1600762694
0.00027 SELECT t.subject, t.closed, t.num_replies, t.sticky, f.id AS forum_id, f.forum_name, f.moderators, fp.post_replies, 0 FROM punbb_topics AS t INNER JOIN punbb_forums AS f ON f.id=t.forum_id LEFT JOIN punbb_forum_perms AS fp ON (fp.forum_id=f.id AND fp.group_id=3) WHERE (fp.read_forum IS NULL OR fp.read_forum=1) AND t.id=30830 AND t.moved_to IS NULL
0.00017 SELECT search_for, replace_with FROM punbb_censoring
0.00115 SELECT u.email, u.title, u.url, u.location, u.use_avatar, u.signature, u.email_setting, u.num_posts, u.registered, u.admin_note, p.id, p.poster AS username, p.poster_id, p.poster_ip, p.poster_email, p.message, p.hide_smilies, p.posted, p.edited, p.edited_by, g.g_id, g.g_user_title, o.user_id AS is_online FROM punbb_posts AS p INNER JOIN punbb_users AS u ON u.id=p.poster_id INNER JOIN punbb_groups AS g ON g.g_id=u.group_id LEFT JOIN punbb_online AS o ON (o.user_id=u.id AND o.user_id!=1 AND o.idle=0) WHERE p.topic_id=30830 ORDER BY p.id LIMIT 0,25
0.00510 UPDATE punbb_topics SET num_views=num_views+1 WHERE id=30830
Total query time: 0.01014 s