Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundacji Dzieciom zdazyć z Pomocą.
Więcej informacji na dug.net.pl/pomagamy/.

#1  2016-01-12 00:02:26

  skullman - Użytkownik

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Quake3 brak dźwięku

Po przesiadce na amd64 nie mogę zrobić dźwięku w Quaku. Już przerabiałem mnóstwo poradników i nic, nawet te najstarsze. Jeśli odpalam normalnie ./quake3 to gra startuje bez dźwięku i dostaję powszechnie znany komunikat:

Kod:

------- sound initialization -------
/dev/dsp: No such file or directory
Could not open /dev/dsp
------------------------------------

a jeśli ./quake3-sdl-sound to gra nie startuje i dostaję coś takiego coś takiego

Kod:

[quake3-sdl-sound] error  : can't locate quake3.x86

Na i386 przed reinstalacją działało wszystko OK, teraz zniknął pakiet libsdl1.2debian-alsa bo chyba to było potrzebne choć pewności nie mam. Ma ktoś może działającego quake'a na amd64?

Offline

 

#2  2016-01-12 07:32:29

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Quake3 brak dźwięku

Kod:

/dev/dsp

oznacza wyjście dźwięku OSS.

Potrzebujesz modułów:

Kod:

snd_pcm_oss
snd_mixer_oss

w kernelu, powinny być załadowane.

Względnie napisz, co w tym Debku za dźwięk odpowiada od strony użyszkodnika, Alsa, Pulseaudio, Jack-audio.

Ostatnio edytowany przez Jacekalex (2016-01-12 07:32:41)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#3  2016-01-12 15:40:55

  morfik - Cenzor wirtualnego świata

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Quake3 brak dźwięku

Tak sobie sprawdziłem u siebie na pulse:

[img]http://i.imgur.com/7jP0BBc.png[/img]

Dźwięk działa jak najbardziej. Na quake2 też działa, idę se postrzelać trochę. xD

Offline

 

#4  2016-01-12 18:34:29

  skullman - Użytkownik

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: Quake3 brak dźwięku

@morfik, nie do końca to miałem na myśli, Ty masz ioquake3 a nie quake3, ja nie chcę tego bubla z dwóch powodów, nie mogę nic rozjaśnić, nawet w konfigu nie mówiąc już o suwaku i dwa nie ładuje mi wszystkich botów a ja często nie gram na sieci.

@Jacekalex. wiem do czego jest /dev/dsp dlatego napisałem, że to powszechnie znany komunikat. Teraz mam pulseaudio, przez pulseaudio działa mi UT2004 bo też wymaga emulacji oss tylko nie wiem, dlaczego jedno działą a drugie nie. No i muszę jeszcze znaleźć sposób na dźwięk w Q3 przez SDL, wcześniej mi dział a teraz milczy jak grób.

Ostatnio edytowany przez skullman (2016-01-12 18:35:57)

Offline

 

#5  2016-01-12 18:39:42

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Quake3 brak dźwięku

Pokaż:

Kod:

ls -l /dev/dsp*

Ostatnio edytowany przez Jacekalex (2016-01-12 18:39:55)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#6  2016-01-12 19:08:32

  skullman - Użytkownik

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: Quake3 brak dźwięku

Kod:

$ ls -l /dev/dsp*
crw-rw-rw- 1 root root 14, 3 sty 12 19:07 /dev/dsp

Offline

 

#7  2016-01-12 19:10:54

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Quake3 brak dźwięku

Dziwny wynik:

U mnie:

Kod:

ls -l /dev/dsp*
crw-rw---- 1 root audio 14,  3 01-12 17:42 /dev/dsp
crw-rw---- 1 root audio 14, 35 01-12 17:42 /dev/dsp2
crw-rw---- 1 root audio 14, 51 01-12 17:42 /dev/dsp3

W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#8  2016-01-12 19:45:07

  morfik - Cenzor wirtualnego świata

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Quake3 brak dźwięku

[quote=skullman]@morfik, nie do końca to miałem na myśli, Ty masz ioquake3 a nie quake3, ja nie chcę tego bubla z dwóch powodów, nie mogę nic rozjaśnić, nawet w konfigu nie mówiąc już o suwaku i dwa nie ładuje mi wszystkich botów a ja często nie gram na sieci.[/quote]
To jak zainstalować to co ty masz? Mogę sprawdzić i to jeśli nie wymaga jakichś wynalazków. Póki co próbuje przejść pierwszy poziom w quake2. xD

Offline

 

#9  2016-01-12 20:20:09

  skullman - Użytkownik

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: Quake3 brak dźwięku

A choćby z tej stronki:
[url]http://www.filewatcher.com/m/linuxq3apoint-1.32b-3.x86.run.30923961-0.html[/url]

Offline

 

#10  2016-01-12 20:45:38

  morfik - Cenzor wirtualnego świata

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Quake3 brak dźwięku

Nie dam rady tego odpalić, nie mam cd i pewnie trzeba by jeszcze jakieś pakiety podociągać. Wolę quake2. xD

Offline

 

#11  2016-01-13 21:57:40

  skullman - Użytkownik

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: Quake3 brak dźwięku

@Jacekalex, to może ja mam coś zrąbane z emulacją OSS-a bo już sporo tu grzebałem. Pokaż może co Ty masz zainstalowane.

Offline

 

#12  2016-01-13 22:20:23

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Quake3 brak dźwięku

Nie używam Pulseaudio, tylko Alsę, do tego moduł snd_pcm_oss w jaju (tryb zgodności z OSS), do tego biblioteka Apulse do Skypa (i ewentualnie, jakby coś jeszcze o PA wołało).

Jak na razie wszystko działa.

Zobacz, czy masz te moduły, jak są, to je załaduj:

Kod:

CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m

To z jajka

Kod:

linux-image-4.3.0-1-grsec-amd64_4.3.3-5+grsec201601051958+1_amd64

Tylko nie wiem, czy Pulse nie będzie walczył z tymi modułami, przy Alsie nie ma problemu.

Ostatnio edytowany przez Jacekalex (2016-01-13 22:23:45)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)

[ Generated in 0.021 seconds, 11 queries executed ]

Informacje debugowania

Time (s) Query
0.00016 SET CHARSET latin2
0.00007 SET NAMES latin2
0.00094 SELECT u.*, g.*, o.logged FROM punbb_users AS u INNER JOIN punbb_groups AS g ON u.group_id=g.g_id LEFT JOIN punbb_online AS o ON o.ident='35.175.133.127' WHERE u.id=1
0.00456 UPDATE punbb_online SET logged=1594015109 WHERE ident='35.175.133.127'
0.00056 SELECT * FROM punbb_online WHERE logged<1594014809
0.00049 SELECT topic_id FROM punbb_posts WHERE id=295385
0.00068 SELECT id FROM punbb_posts WHERE topic_id=28087 ORDER BY posted
0.00068 SELECT t.subject, t.closed, t.num_replies, t.sticky, f.id AS forum_id, f.forum_name, f.moderators, fp.post_replies, 0 FROM punbb_topics AS t INNER JOIN punbb_forums AS f ON f.id=t.forum_id LEFT JOIN punbb_forum_perms AS fp ON (fp.forum_id=f.id AND fp.group_id=3) WHERE (fp.read_forum IS NULL OR fp.read_forum=1) AND t.id=28087 AND t.moved_to IS NULL
0.00007 SELECT search_for, replace_with FROM punbb_censoring
0.00097 SELECT u.email, u.title, u.url, u.location, u.use_avatar, u.signature, u.email_setting, u.num_posts, u.registered, u.admin_note, p.id, p.poster AS username, p.poster_id, p.poster_ip, p.poster_email, p.message, p.hide_smilies, p.posted, p.edited, p.edited_by, g.g_id, g.g_user_title, o.user_id AS is_online FROM punbb_posts AS p INNER JOIN punbb_users AS u ON u.id=p.poster_id INNER JOIN punbb_groups AS g ON g.g_id=u.group_id LEFT JOIN punbb_online AS o ON (o.user_id=u.id AND o.user_id!=1 AND o.idle=0) WHERE p.topic_id=28087 ORDER BY p.id LIMIT 0,25
0.00730 UPDATE punbb_topics SET num_views=num_views+1 WHERE id=28087
Total query time: 0.01648 s